Azure AD Connect high (100%) CPU usage after update


Today I updated my demo lab VMs with the latest patches from July 2018.

Some time after the reboot the machine starts to use 100% CPU ending in slow responses to nearly become unusable.

From the task manager (takes 30-60 seconds to start) I could see one process consuming all the CPU power:

Microsoft.Online.Reporting.MonitoringAgent.Startup

The server was operating fine before the updates and since some .NET fixes where included I assumed one of them to be responsible.

I started by uninstalling in the following order:

KB 4338419

KB4338815

KB4054566

I rebooted the server after every uninstall of an KB update but only after the server was stable not consuming high CPU.
So I cannot exactly tell which of the updates are responsible for the issue.

I found an article in the Technet Forum after my tests and it seems to me that the updates which are responsible varies from system to system.
https://social.msdn.microsoft.com/Forums/en-US/e9b621f6-f38c-488e-8fcb-ff85d406f256/azure-ad-connect-health-sync-monitor-high-cpu-usage?forum=WindowsAzureAD

 

My system is:

Windows Server 2012 R2
Azure AD Connect 1.1.819.0

Advertisements

Author: Peter Stapf

Senior Consultant Identity and Access

One thought on “Azure AD Connect high (100%) CPU usage after update”

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.